v642 Workshop

Aus FunkFeuer Wiki
Wechseln zu: Navigation, Suche
v642 Workshop
Datum

19 Dez. 18, 18:00 bis 19 Dez. 18, 20:30

Ort

Uni Wien, Fakultät für Mathematik Seminarraum SR6 Oskar-Morgenstern-Platz 1 1090 Wien https://www.openstreetmap.org/relation/1529002 (nahe U4 Rossauer Lände)

Event wahr


Google Hangout: https://hangouts.google.com/call/JuOBkr49wiuHnkPnKJLEAEEI Was ist v642?

IPv6 = 6 IPv4 = 4 OLSRv2 = 2

Projekte/v642

Map Basemap: ist nur OLSRv1 OLSRv2-Map:

  • ) Grüne Punkte sind (auch) OLSRv2 fähig und aktuell erreichbar
  • ) Rote Punkte sind OLSRv2-aktiv, aber von der Topologie isoliert
  • ) weiße Punkte: kein OLSRv2, aber OLSRv1 mit IPv4 online

...mehr Infos dazu: Benutzer:Pocki#OLSRv2-Map

Ein UserInterface für v642 für OpenWrt (Stichwort "LuCI-Plugin") muss noch entwickelt werden. Freiwillige vor! IPv6-Adressplan

Siehe Wiki: IP-Adresskonzept

Early Registration: ursprüngliches IPv6-Konzept via Tunnel auf olsrd6(v1), 2a02:60; EOL und im Auslaufen!

2a02:61::/32 ist das v642 zugeordnete Subnetz, das aktuell in Verwendung ist und mit olsrd2 genutzt wird.

/48 für Infrastruktur

Adress-Nutzung eines Routers (ipv4@olsrv1 vs. ipv6@olsrv2): olsr1: eine (globale) IPv4 für jedes olsr1-aktivierte Interface olsr2: eine (globale) IPv6 für die OLSRv2-Instanz (also eine pro Router), zugeordnet auf loopback-Interface "lo". Die einzelnen OLSRv2-aktivierten Interfaces nutzen Link-local-IPv6-Adressen fe80::/64, um mit ihren OLSRv2-nachbarn zu kommunizieren/zu routen.

EUI-64-generierte Adressen sind möglich und erlaubt, es gibt aber noch keine kanonische Rückwärtsnamensauflösung (abseits der Heuristiken in den Ubiquiti-Wizards).

ff01: - Multicast OpenWRT-Demo

Relevantes opkg:

opkg install oonf-olsrd2

Relevante Konfigdateien: /etc/config/network

nota bene, IPv6-Adresse für Loopback-Interface setzen! (Per EUI-64, oder manuell, egal) /etc/config/olsrd2

(Da wären BCPs herrlich! Z.B. wann/warum was black-/whitelisten?)

originator --- Absendeadresse meiner OLSR-Pakete

config interface

list originator alle die nicht kongfiuriert sind werden nicht von olsr angepsrochen

auf loopback wird nichts rausgeschickt

auf tonode4 (jeweils pro interface)

auf Loopback-Adressen rausschicken, alle interfaces auf bridges auch ansprechen

"ip -6 route show" um routen anzuzeigen

"mtr 2a02:61:3::1" zeigt traceroute an, wobei 3 hier die nummer vom node ist Ubiquiti-Demo

Benutzer:Pocki#ER-wizard-OLSRd_V2

Datei:OLSRd V2 Wizard.pdf

Entweder EUI64, oder IP aus Userblock

Wizard erkennt nodeid über IPv4-OLSRv1 durch das Redeemer-Portal (sofern Netzwerkverbindung schon vorhanden)

Loopback Interface hat EUI64 Originator IP zugewiesen, mit dieser meldet sich OLSRdv2 bei allen anderen.

lo und br0 ist von Haus aus aktiviert, weitere müssen manuell aktiviert werden.

Im OLSR2 Config-File Interface-Zeilen, ungewünschte Adressen sind explizit geblacklistet.

Additional Announcements für lokale Präfixe, so wie HNA4.

Einrichting von Edgerouter mit OLSRdv1 (ist nicht Vorraussetzung, Install geht auch ohne olsrv1)

Installieren von OLSRdv2 Wizard, warten bis fertig, 10 Sekunden,

Haken bei EUI64 Assigned setzen, dann Apply. Reload der Webseite zeigt: Läuft schon.

olsr2-interfaces im Wizard noch nicht änderbar, aber per SSH einloggen und in olsrd2.conf anpassen

show interfaces zeigt EUI64 auf lo Interface

ping6 nic.at

Von anderem Gerät traceroute6 zur EUI64 2a02:61:0:ff

im /config/olsrd2/olsr2.conf

Hier ist alles konfiguriert, als originator-Adressen werden ipv4, 2a02:60: und Wrapper ausgeschlossen.

Persistent über Firmwareupdate.

Wizard unterstützt das Aktiveren eines (vorerst nur eines) LAN-interfaces für lokale Clients: automatische IPv6-Vergabe an diese Clients, Firewall outside-to-inside

Status-Seite zu olsrd2 kann über den Wizard "WSLE - WebStatus/LetsEncrypt" ergänzt werden HNA (LAN)

Host Network Announcement (OLSRv1 HNA4), LAN Announcement (OLSRv2)

/etc/config/olsrd2 --> list 'lan' '$NETZ domain=0' # was auch immer jenes Netz ist domain=0 muss dort stehen IPv4 Wrapping

IPv4-Pakete werden stateless in IPv6-Pakete eingepackt, nicht getunnelt im herkömmlichen Sinne: Das Ein-/Auspacken können unabhängig voneinander verschiedene Wrapper im Netz für verschiedene Pakete desselben Flows erledigen. Umgekehrt (asymmetrische Route!) wird die IPv4-Adresse eines v642-Knotens nur von diesem Knoten announcet.

ip-Befehle dazu siehe Wolfgangs Transkript

Siehe auch:

Projekte/v642/IPv4_Support

IP-Adresskonzept#IPv4-Adressen_f.C3.BCr_Nodes

Projekte/v642/IPv4_Liste

   tcpdump -ni br-tonode4 net 2a02:61:0:ee::/64

2a02:61:0:ee::/64 ist IPv4, 0 oder 1 danach In / Out

Konfiguration von Antenne mit OpenWRT für IPv6

/etc/config/wireless

config wifi-device 'radio0'
option type 'mac80211'
option channel 'auto'
option hwmode '11n'
option path 'platform/ar934x_wmac'
config wifi-iface 'default_radio0'
option device 'radio0'
option network 'ff'
option mode 'sta'
option ssid 'your-ssid-here.funkfeuer.at'
option encryption 'none'

/etc/config/network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
list ip6addr '2a02:61:your-hex-nodeid-here::1/128'
config interface 'ff'
option proto 'static'
option ipaddr '193.238.156.your-ip-here'
option netmask '255.255.255.255'

/etc/config/olsrd

config olsrd
# uncomment the following line to use a custom config file instead:
#option config_file '/etc/olsrd.conf'
config Interface
list interface 'ff'

/etc/config/olsrd2

config global
option 'failfast' 'no'
option 'pidfile' '/var/run/olsrd2.pid'
option 'lockfile' '/var/lock/olsrd2'
config log
option 'syslog' 'true'
option 'stderr' 'true'
config olsrv2
list 'originator' '2a02:61:your-hex-nodeid-here::/64'
list 'originator' 'default_reject'
config interface
list 'ifaddr_filter' 'default_reject'
list 'bindto' 'default_reject'
config interface
list 'ifname' 'loopback'
list 'ifaddr_filter' '2a02:61:your-hex-nodeid-here::/64'
list 'ifaddr_filter' 'default_reject'
list 'bindto' 'default_reject'
config interface
list 'ifname' 'ff'
list 'ifaddr_filter' 'default_accept'
list 'bindto' 'fe80::/64'
list 'bindto' 'default_reject'

Firewall beim Testen ausschalten und wenn es funktioniert entsprechend anpassen.

olsrd6 (alter olsr fuer IPv6) wuerde ich /etc/init.d/olsrd6 sollte disabled werden

Wireless config ist entsprechend dem Netz anzupassen.